You are viewing jackyf

Previous Entry | Next Entry

cupt: 2.0.0~beta1

feterny-bird
Cupt v2 has reached a beta stage.

Main news of Cupt v2 comparing to Cupt v1 are grouped here.

Notable changes since 2.0.0~alpha3:

  • New configurable score calculation system in the native resolver (new option group 'cupt::resolver::tune-score::*')
  • Added an ability to specify additional package expressions and restart the solving process in the action preview prompt (new choice 'a')
  • When no solutions were found, throw an error with a solution tree(s) to show why.
    Example:
    $ cupt-experimental -s -R remove kdepimlibs-kio-plugins kdebase-workspace+
    Building the package cache...
    Initializing package resolver and worker...
    Scheduling requested actions...
    Resolving possible unmet dependencies...
    E: unable to resolve dependencies, because of:
    
    plasma-widgets-workspace 4:4.4.5-8 depends on 'plasma-dataengines-workspace (= 4:4.4.5-8)' -> no solutions
      plasma-dataengines-workspace 4:4.4.4-1 depends on 'kdepim-runtime' -> removed plasma-dataengines-workspace
        kdepim-runtime 4:4.4.3-1 depends on 'kdepimlibs-kio-plugins' -> removed kdepim-runtime
      plasma-desktop 4:4.4.5-8 depends on 'plasma-widgets-workspace (= 4:4.4.5-8)' -> installed plasma-widgets-workspace 4:4.4.5-8
        kdebase-workspace-bin 4:4.4.5-8 depends on 'plasma-desktop (= 4:4.4.5-8) | plasma-netbook (= 4:4.4.5-8)' -> installed plasma-desktop 4:4.4.5-8
          kdebase-workspace 4:4.4.5-8 depends on 'kdebase-workspace-bin (>= 4:4.4.5-8)' -> installed kdebase-workspace-bin 4:4.4.5-8
    
    plasma-dataengines-workspace 4:4.4.5-8 depends on 'kdepim-runtime' -> no solutions
      kdepim-runtime 4:4.4.3-1 depends on 'kdepimlibs-kio-plugins' -> removed kdepim-runtime
      plasma-widgets-workspace 4:4.4.5-8 depends on 'plasma-dataengines-workspace (= 4:4.4.5-8)' -> installed plasma-dataengines-workspace 4:4.4.5-8
        plasma-netbook 4:4.4.5-8 depends on 'plasma-widgets-workspace (= 4:4.4.5-8)' -> installed plasma-widgets-workspace 4:4.4.5-8
          kdebase-workspace-bin 4:4.4.5-8 depends on 'plasma-desktop (= 4:4.4.5-8) | plasma-netbook (= 4:4.4.5-8)' -> installed plasma-netbook 4:4.4.5-8
            kdebase-workspace 4:4.4.5-8 depends on 'kdebase-workspace-bin (>= 4:4.4.5-8)' -> installed kdebase-workspace-bin 4:4.4.5-8
    
    
    E: error performing command 'remove'
    


Full changelog is available in debian/changelog, as usual.

binary packages for i386, source package and README

Tags: